No arranca!!! No detecta palanca en P!

Modelos Jaguar XJ 300 & 308
raulfernandezcuevas
En rodaje...
En rodaje...
Mensajes: 18
Registrado: 30 Jun 2020 13:13

No arranca!!! No detecta palanca en P!

Mensaje sin leer por raulfernandezcuevas »

Buenos días a todos!!

A ver si me podéis hechar una mano.
Resulta que mi jaguar lleva ya tiempo q me falla al detectar la palanca en “P” al arrancar, pero con mover un pelin la palanca ya se encendía la luz, pero hoy ya directamente no hay manera de que se encienda la luz y no me deja arrancar el coche.

He probado a desmontar el embellecedor y girar un poco la pletina q pulsa cuando la palanca está en P, pero tampoco.
Si q he visto q haciendo presión en los cables y moviendo un poco la palanca se llegaba a encender un momento pero se volvía a apagar, pero ya no hay manera ninguna.

A ver si me podéis indicar que más puedo mirar antes de tener q llevarle a un taller jaguar. Se me está ocurriendo de lo malo cortar los cables a ver si es eso…. Pero ya como último recurso.

Y en caso de tener que llevar que creéis que puede ser y cuanto puede costar.

Gracias de antemano!!! Saludos!!
3B1FD336-A362-4B08-931C-ECE0C9B21863.jpeg
A92917C7-6298-4609-8D5A-F2D506373C1F.jpeg
jalvarez
Cortando encendido...
Cortando encendido...
Mensajes: 2727
Registrado: 08 Abr 2010 13:07
Ubicación: Madrid

Re: No arranca!!! No detecta palanca en P!

Mensaje sin leer por jalvarez »

Hola raulfernandezcuevas,

Yo tengo un S-Type, no tengo un X300, pero el mecanismo creo que es el mismo. Un micro-interruptor contra el que choca la palanca y que si no choca, no desenclava el gancho que la mantiene en la posición P hasta que no pises el freno de pié. Creo que debe ser ese interruptor del que salen los cables azul y negro-blanco de la foto que has puesto, que está fijado con 2 tornillos. Casi seguro que le ha entrado grasa y hace mal contacto. Prueba a limpiarlo con spray limpiacontactos de resíduo cero, que se compra en cualquier tienda de electrónica o por Internet.

Saludos
Javier
raulfernandezcuevas
En rodaje...
En rodaje...
Mensajes: 18
Registrado: 30 Jun 2020 13:13

Re: No arranca!!! No detecta palanca en P!

Mensaje sin leer por raulfernandezcuevas »

Buenas, gracias por responder.
He conseguido un limpia contactos de la marca DW.
¿Le doy a toda la pieza negra? A los cables también? O solo a la plaqueta metálica?

Gracias de nuevo!!!
raulfernandezcuevas
En rodaje...
En rodaje...
Mensajes: 18
Registrado: 30 Jun 2020 13:13

Re: No arranca!!! No detecta palanca en P!

Mensaje sin leer por raulfernandezcuevas »

Buenas a todos!!

Después de recorrerme foros de jaguar en inglés di con mi problema.

Lo que falla es una especie de sensor que va junto a la palanca en el lado derecho, lo llaman “linear switch” en los foros ingleses. Al mover la palanca, mueve otra pieza por un carril que es la que va indicando al coche en que posición está la palanca.

La pieza negra es la que falla, la pieza blanca es lo que se mueve junto con la palanca para indicar la posición:
Linear switch
Linear switch
En los foros ingleses he visto que es una pieza que ya no se vende, que falla mucho y que solo se puede comprar de segunda mano de algún despiece.
Encontré un pdf con todos los diagramas eléctricos del coche, asiq hay vi qué cables eran los que indicaban que la palanca está en posición ‘P’. (Lo adjuntare si puedo)
Cables
Cables
El cable negro es el que entra la corriente al linear switch, el naranja es el que manda la señal de que la palanca está en posición ‘P’, en principio con estos dos cablea valdría, el otro que tengo cortado que es gris y morado es el que hace que se ilumine la ‘P’ del selector. En mi caso he hecho un puente con un interruptor entre estos cables. He dejado también los cables originales unidos de nuevo, ya que si no no funcionaría la luz de marcha atrás al poner la palanca en R, y tampoco se iluminarían las letras en el selector.

Es una solución fácil y barata, aunq no la mejor jeje.
Al final así es como lo he dejado, el interruptor lo voy a meter en el compartimento del cenicero, así no se ve a la vista.
Mientras el interruptor esté en posición off no arranca el coche. (También sirve como antirrobo jajaj)
Cables unidos
Cables unidos
Interruptor
Interruptor

Espero que a alguien le sirva de ayuda.
Mañana dejaré ya el interruptor dentro del cenicero y os pongo foto de cómo a quedado y adjunto el pdf de los diagramas eléctricos.

Saludos!!
Avatar de Usuario
TheShadow
Cortando encendido...
Cortando encendido...
Mensajes: 8750
Registrado: 02 Jun 2006 18:52
Ubicación: Madrid
Contactar:

Re: No arranca!!! No detecta palanca en P!

Mensaje sin leer por TheShadow »

:supz: :supz: :supz:
raulfernandezcuevas
En rodaje...
En rodaje...
Mensajes: 18
Registrado: 30 Jun 2020 13:13

Re: No arranca!!! No detecta palanca en P!

Mensaje sin leer por raulfernandezcuevas »

Buenas!

Así es como ha quedado finalmente:
84F093AD-8C6D-41A0-A3DF-E0F4D121A009.jpeg
Una vez cerrada la tapa del cenicero no se ve el interruptor. Solo tengo q ponerlo en ON para arrancar y listo.
Aun así he comprado la pieza de segunda mano por ebay uk de ara tenerla por si acaso.

Saludos!
Responder