ALARMAS VARIAS SALPICADERO

Modelos Jaguar X-Type
TheJokerman
Acelerando...
Acelerando...
Mensajes: 62
Registrado: 30 Ago 2015 18:43

Re: ALARMAS VARIAS SALPICADERO

Mensaje sin leer por TheJokerman » 11 Sep 2017 22:35

jalvarez escribió:
11 Sep 2017 19:50
Hola TheJokerman:

Verifica que todas las conexiones a masa (terminales atornillados con el chasis), no estén oxidados. Hay un producto (pasta) para mejorar la condcutividad.

Sobre las conexiones a masa de la pantalla de los cables de par trenzado, es muy importante que la pantalla no esté rota y que en ambos extremos haga buen contacto con masa. Si un extremo hiciese mal contacto y la fuente interferente estuviese en medio (se me ocurre que la fuente más interferente es el alternador, y quizás los pulsos de excitación de los inyectores), se produciría lo que se conoce como un rebote de tierra.

En el vehículo quien hace de amortiguador de interferencia es la batería (mismo problema que en los satélites), por tanto, toda fuente interferente, debería tener la conexión lo más cerca posible de la batería. Verifica que el cable negativo de la batería hace buen contacto con el chasis.
Hola tocayo. En cuanto a la calidad de las masas tienes razón, son muy importantes, y las he repasado de punta a cabo, las del vano motor y las del salpicadero. También veo como fuente interferente al alternador, pero me alivia pensar que tiene bastante proximidad en cable grueso con la batería, y que su frecuencia de trabajo es relativamente baja frente a la del CAN BUS. La que realmente me mosquea es la del sensor de picado, que precisamente si es piezoeléctrico puede ser muy coñazo, sobre todo por el empalme que hay en el mazo. Voy a ver si puedo colgar una foto del mismo y otra del cambio en los esquemas. Otra cosa que me mosquea es que los cableados en las series posteriores van trenzados, todos los de sensores, mientras que en el mío únicamente van los de buses de datos. Técnicamente un trenzado general pseudo-apantalla a su par ruidoso.
He estado leyendo acerca de las frecuencias de trabajo de pares trenzados y de apantallados, y la mejoría en los apantallados es notable, con lo que por el bajo coste que me supone voy a hacerlo, y como bien dices, llevando a masa ambos extremos.
jalvarez escribió:
11 Sep 2017 19:50


La razón por la que, sin funcionar el cuadro de instrumentos, te sigue funcionando el software del PC, conectado por OBD, es porque los mensajes siguen estando ahí, los pone el ECU PCM (gobierna el motor) y el ECU ABS (gobierna los frenos), cosa distinta es que el ECU IC (gobierna el cuadro de instrumentos) no sea capaz de presentar nada porque está deteriorado. Por favor busca en Youtube "bad capacitor on instrument cluster Jaguar X-type", recuerdo haber visto algo sobre un problema con un condensador, que puede formar parte de un filtro y ese podría ser el causante de todo, aunque si has sustituido el ECU IC y lo hace con los 2, es poco probable.

Los buses para estabilizar su impedancia (misma resistencia a lo largo de todo el cable), llevan una resistencia en el ECU donde empiezan y una en el ECU que finalizan. El bus CAN de alta velocidad (500Kbps) que conecta todos los ECU del tren motriz, empieza en el IC (cuadro de instrumentos) y termina en el ECU PCM (control del motor). Verifica que hay una resistencia de 120 Ohm en ambos y que no vaya a estar desoldada en alguno o que al subir la temperatura una de ellas deje de hacer buen contacto. Esto es muy importante. La forma de ver si hay problemas de interferencia en el bus CAN, sería con un osciloscopio con capacidad de grabación y frecuencia de muestreo minima 4 x 500.000 = 2 MHz (4 puntos por ciclo) y sincronización de disparo configurable positiva/negativa. Lo ideal sería contar con un analizador de bus CAN, que salvo en laboratorios de Politécnicos de Industriales, no se me ocurre donde puede haber.

Importantísimo, los cables del bus CAN tienen que entrar y salir del conector para saltar de un ECU a otro, no se pueden hacer rabillos (se descompensa el bus).

El bus SCP, ese aparentemente está funcionando bien, no lo toques. Ese tiene topología física radial y lógica de bus.

Saludos
Javier
En lo que te refieres del cuadro, tienes razón en cuanto a la susceptibilidad a errores, pienso yo también que por la distancia que lleva la información desde el mazo del ABS hasta el cuadro, dos metros de cable, y es el primer error que me sale, "control de velocidad no disponible", seguido de ABS, seguramente al cuadro le llega demasiado ruido. Eso sí, descarto fallos en el cuadro, porque no en vano, he probado 5... y con todos falla.
Las resistencias de final de línea están correctas.
Te pregunto para centrarme más o no en el cable del sensor de picado, si en frío la electrónica retrasa mucho la inyección a costa del consumo, para evitar el picado con el aceite frío. Es que en frío no da la castaña, y por construcción de los sensores de temperatura de motor, o de presión, el cortocircuito intermitente se me antoja difícil.

Gracias por tu ayuda y un abrazo.

jalvarez
A tope...
A tope...
Mensajes: 1497
Registrado: 08 Abr 2010 13:07
Ubicación: Madrid

Re: ALARMAS VARIAS SALPICADERO

Mensaje sin leer por jalvarez » 12 Sep 2017 08:15

TheJokerman escribió:
11 Sep 2017 22:35
...Te pregunto para centrarme más o no en el cable del sensor de picado, si en frío la electrónica retrasa mucho la inyección a costa del consumo, para evitar el picado con el aceite frío. Es que en frío no da la castaña, y por construcción de los sensores de temperatura de motor, o de presión, el cortocircuito intermitente se me antoja difícil...
Hola TheJokerman:

El sensor de picado es un acelerómetro y su conexión es flotante al ECU PCM, por tanto, éste no genera interferencia alguna, salvo que como indicas estén empalmados los cables y alguno de ellos haga contacto con el chasis del vehículo. Sin poder pinchar un osciloscopio (que tiene que tener entrada flotante de 2 canales y poder ponerlos en modo diferencial o 1 canal, siempre que el osciloscopio se alimente con batería y sin contacto metálico alguno con el vehículo), va a ser muy difícil identificar el ECU que está generando el problema, suponiendo que el problema sea la transmisión en el bus CAN.

Los cables del bus CAN son de tipo multifilar (muchos hilos delgados para generar mucha superficie) debido a que la alta frecuencia se conduce por efecto pelicular (por la piel del conductor). Si hay muchos empalmes es una buena razón para que no funcione.

Respecto del cableado apantallado o no apantallado, manifestar que una pantalla puesta al mismo potencial en ambos extremos, siendo éste el potencial cero de referencia, es un elemento de protección, pero si esto no se cumple, se comporta como una antena de captación de todo el ruido eléctrico ambiente.

Sugiero tengas respuesta a la siguiente pregunta: ¿Todos y cada uno de los ECU conectados al bus CAN del tren motriz tienen la versión de firmware, que según la matriz de compatibilidad de Jaguar se entienden entre si, es decir, todos comparten la misma semántica y sintaxis para todos los mensajes?.

Saludos
Javier

TheJokerman
Acelerando...
Acelerando...
Mensajes: 62
Registrado: 30 Ago 2015 18:43

Re: ALARMAS VARIAS SALPICADERO

Mensaje sin leer por TheJokerman » 12 Sep 2017 09:16

jalvarez escribió:
12 Sep 2017 08:15
TheJokerman escribió:
11 Sep 2017 22:35
...Te pregunto para centrarme más o no en el cable del sensor de picado, si en frío la electrónica retrasa mucho la inyección a costa del consumo, para evitar el picado con el aceite frío. Es que en frío no da la castaña, y por construcción de los sensores de temperatura de motor, o de presión, el cortocircuito intermitente se me antoja difícil...
Hola TheJokerman:

El sensor de picado es un acelerómetro y su conexión es flotante al ECU PCM, por tanto, éste no genera interferencia alguna, salvo que como indicas estén empalmados los cables y alguno de ellos haga contacto con el chasis del vehículo. Sin poder pinchar un osciloscopio (que tiene que tener entrada flotante de 2 canales y poder ponerlos en modo diferencial o 1 canal, siempre que el osciloscopio se alimente con batería y sin contacto metálico alguno con el vehículo), va a ser muy difícil identificar el ECU que está generando el problema, suponiendo que el problema sea la transmisión en el bus CAN.

Los cables del bus CAN son de tipo multifilar (muchos hilos delgados para generar mucha superficie) debido a que la alta frecuencia se conduce por efecto pelicular (por la piel del conductor). Si hay muchos empalmes es una buena razón para que no funcione.

Respecto del cableado apantallado o no apantallado, manifestar que una pantalla puesta al mismo potencial en ambos extremos, siendo éste el potencial cero de referencia, es un elemento de protección, pero si esto no se cumple, se comporta como una antena de captación de todo el ruido eléctrico ambiente.

Sugiero tengas respuesta a la siguiente pregunta: ¿Todos y cada uno de los ECU conectados al bus CAN del tren motriz tienen la versión de firmware, que según la matriz de compatibilidad de Jaguar se entienden entre si, es decir, todos comparten la misma semántica y sintaxis para todos los mensajes?.

Saludos
Javier
Hola Javier, justamente lo que me preocupa es el empalme, y lo mal hecho que esté. Dudo que una frecuencia audible (15 kHz) pueda interferir porque sí en una comunicación a 1 MHz...
Las ECUs originales del coche deben llevar el software de la misma versión, las otras que he probado aún no siendo de exactamente la misma referencia, han funcionado exactamente igual.

Me preocupa más la capa física, sobre todo por el cambio en el trenzado en los esquemas. Esta tarde le meto mano de nuevo, y ya os contaré lo que vea.

TheJokerman
Acelerando...
Acelerando...
Mensajes: 62
Registrado: 30 Ago 2015 18:43

Re: ALARMAS VARIAS SALPICADERO

Mensaje sin leer por TheJokerman » 17 Nov 2017 18:47

Seguimos "on fire" con el cochecito...

El coche ha vuelto a pasar por el taller del "especialista", y tras varias semanas más, prueba de toooodas las unidades electrónicas imprescindibles para funcionar, y con las demás unidades desconectadas; probadas otras unidades de fusibles, medidos todos los cableados por enésima vez, el coche sigue fallando.
Datos objetivos obtenidos de la experiencia, y agradeciendo al mecánico que se ha esforzado hasta acabar negro y rendirse,
bueno, darme una solución de matar moscas a cañonazos por la desesperación.
- Al cambio de alternador ha cambiado el rango de comportamiento de fallos.
- Ahora falla en carretera y casi nunca en urbano.
- Con el ETM activado, al fallar de forma esporádica el voltaje cae momentáneamente desde 13'7 a 12'1.
- Cuando falla de forma repetitiva el cable que va al positivo de la batería se pone caliente como el cenicero de un bingo.
- Ha dejado de fallar al girar a izquierda.
- Cuando va tonto, el fallo se activa al demandar consumo eléctrico en todo lo relacionado con el motor (solenoides de turbo, inyección, solenoide regulador de la bomba de alta, etc...), es decir al pisar a fondo a partir de 1900 rpm.
- Al coche le cuesta arrancar en caliente peeeero la batería y el filtro de gasoil son nuevos, y los inyectores están perfectamente, verificados tanto con las probetas como con el offset que devuelven por diagnosis.


Así, que me decanto porque pueda tener un fallo por contacto en la puesta en marcha, más concretamente que el Bendix meta corriente por su cuenta al motor de arranque, incluso sin que el solenoide lo posicione engranando al dentado del volante motor.

Explicación teórica: Si sucede esto, con el motor de arranque girando loco cuando le da la gana, por arte de birlo birloque, su consumo haría calentar el cable de positivo que recorre desde la puesta en marcha hasta el alternador pasando por la batería. El negativo no se calienta porque ese paso de corriente se efectuaría por la masa que ejerce el propio bloque de motor mayoritariamente.
Creo que de ser así, los picos de consumo con su correspondiente caída de voltaje, de forma tan errática afectarían a las comunicaciones CAN, máxime teniendo en cuenta que su "apertura" es de 2'5 voltios, que están muy cerca de los 1'7 de caída que he visto en el ETM.
Lo de costar más arrancar en caliente lo achaco a que al calentarse mucho la puesta en marcha, le cuesta más tirar del motor.

Acepto sugerencias y que me cuestionéis el diagnóstico. También acepto que me digáis chalado y cosas similares, sé que me lo merezco.

Responder

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 6 invitados